get cisco power consumption 3945

cisco7

You can get power consumption information of your cisco router with show environment command.

This is output of my cisco 3945 router

Border#show environment
SYSTEM POWER SUPPLY STATUS
==========================
Internal Power Supply 1 Type: AC
Internal Power Supply 1 12V Output Status: Normal

Internal Power Supply 2 Type: Absent

SYSTEM FAN STATUS
=================
Fan 1 OK, Low speed setting
Fan 2 OK, Low speed setting
Fan 3 OK, Low speed setting
Fan 4 OK, Low speed setting
Fan 5 OK, Low speed setting

SYSTEM TEMPERATURE STATUS
=========================
Intake Left temperature: 17 Celsius, Normal
Intake Right temperature: 16 Celsius, Normal
Exhaust Right temperature: 17 Celsius, Normal
Exhaust Left temperature: 19 Celsius, Normal
CPU temperature: 50 Celsius, Normal
Power Supply Unit 1 temperature: 19 Celsius, Normal

REAL TIME CLOCK BATTERY STATUS
==============================
Battery OK (checked at power up)

SYSTEM POWER
===============
Motherboard Components Power consumption = 95.5 W
Total System Power consumption is: 95.5 W

Environmental information last updated 00:00:23 ago

As you see the Total System Power consumption is: 95.5 W

connect to your cisco device using ckermit tool

console+cable

usb-to-serial

dmesg
[ 9476.461366] usb 4-5: Product: USB2.0-Ser!
[ 9476.461672] usb 4-5: configuration #1 chosen from 1 choice
[ 9476.579758] usbcore: registered new interface driver usbserial
[ 9476.579800] USB Serial support registered for generic
[ 9476.579856] usbcore: registered new interface driver usbserial_generic
[ 9476.579861] usbserial: USB Serial Driver core
[ 9476.582778] USB Serial support registered for ch341-uart
[ 9476.582797] ch341 4-5:1.0: ch341-uart converter detected
[ 9476.617800] usb 4-5: ch341-uart converter now attached to ttyUSB0
[ 9476.617838] usbcore: registered new interface driver ch341

aptitude install ckermit

vim ~/.kermrc
set line /dev/ttyUSB0
set speed 9600
set carrier-watch off
set handshake none
set flow-control none
robust

client-120:/home/bentoslack# kermit
C-Kermit 8.0.211, 10 Apr 2004, for Linux
Copyright (C) 1985, 2004,
Trustees of Columbia University in the City of New York.
Type ? or HELP for help.
(/home/ibekyarov/) C-Kermit>connect
Connecting to /dev/ttyUSB0, speed 9600
Escape character: Ctrl-\ (ASCII 28, FS): enabled
Type the escape character followed by C to get back,
or followed by ? to see other options.
----------------------------------------------------

Switch>

Switch>show version
Cisco Internetwork Operating System Software
IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5.3)WC(1), MAINTENANCE INTERIM SOFTWARE
Copyright (c) 1986-2001 by cisco Systems, Inc.
Compiled Mon 30-Apr-01 07:51 by devgoyal
Image text-base: 0x00003000, data-base: 0x003331F4

ROM: Bootstrap program is C3500XL boot loader

Switch uptime is 34 minutes
System returned to ROM by power-on
System image file is "flash:c3500XL-c3h2s-mz-120-5.3.WC.1.bin"

cisco WS-C3548-XL (PowerPC403) processor (revision 0x01) with 16384K/1024K bytes of memory.
Processor board ID FOC0548T066, with hardware revision 0x00
Last reset from power-on

Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode.

I got this error message during reconfiguration of cisco switch 3560G series.
Before configure a “trunk” mode we have to configure encapsulation.

to solve the problem

(config-if)#switchport trunk encapsulation dot1q
(config-if)#switchport mode trunk

now, everything is good, we can add vlans in this way

(config-if)#switchport trunk allowed vlan add 10

%SW_VLAN-4-VLAN_CREATE_FAIL: Failed to create VLANs 3310: extended VLAN(s) not allowed in current VTP mode% Failed to create VLANs 3310 Extended VLAN(s) not allowed in current VTP mode. %Failed to commit extended VLAN(s) changes.

(config)#do sh vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : ”
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 2893.fe93.1800
Configuration last modified by 0.0.0.0 at 3-1-93 00:29:31
Local updater ID is 0.0.0.0 (no valid interface found)

Feature VLAN:
————–
VTP Operating Mode : Server
Maximum VLANs supported locally : 1005
Number of existing VLANs : 15
Configuration Revision : 54
MD5 digest : 0xC7 0xDA 0xF2 0xC3 0xA4 0xC3 0x89 0xD5
0xD0 0x23 0xB7 0x8E 0x40 0x53 0x64 0x43

I will not use a VTP protocol.
In my case I can stopped it.

(config)#vtp mode off

configuring dhcp server

пускаме дцп сървър

ip dhcp excluded-address  192.168.0.1 192.168.0.5

ip dhcp pool LAN

network 192.168.0.0

default-router 192.168.0.1

dns-server 192.168.0.5

domain-name  domain.net

някои други полезни команди

show ip dhcp binding

show ip dhcp server statistics

show ip dhcp pool

nameif command

pixfirewall(config)# show nameif
nameif ethernet0 outside security0
nameif ethernet1 inside security100

pixfirewall(config)# nameif ethernet0 WAN security0
pixfirewall(config)# nameif ethernet1 LAN security99

pixfirewall(config)# show nameif
nameif ethernet0 WAN security0
nameif ethernet1 LAN security99

ако пробваме

pixfirewall(config)# nameif ethernet1 LAN security100

ще видим следната грешка:

security 100 is reserved for the “inside” interface

cisco ios show commands

pixfirewall# show version

Cisco PIX Firewall Version 6.3(4)
Cisco PIX Device Manager Version 3.0(2)

Compiled on Fri 02-Jul-04 00:07 by morlee

pixfirewall up 2 mins 18 secs

Hardware:   PIX-501, 16 MB RAM, CPU Am5x86 133 MHz
Flash E28F640J3 @ 0x3000000, 8MB
BIOS Flash E28F640J3 @ 0xfffd8000, 128KB

0: ethernet0: address is 0012.dab7.b5cd, irq 9
1: ethernet1: address is 0012.dab7.b5cf, irq 10
Licensed Features:
Failover:                    Disabled
VPN-DES:                     Enabled
VPN-3DES-AES:                Enabled
Maximum Physical Interfaces: 2
Maximum Interfaces:          2
Cut-through Proxy:           Enabled
Guards:                      Enabled
URL-filtering:               Enabled
Inside Hosts:                10
Throughput:                  Unlimited
IKE peers:                   10

This PIX has a Restricted (R) license.

Serial Number: 808512341 (0x3030eb55)
Running Activation Key: 0x72371258 0x70e6bcd7 0x4ba1467e 0x073d9180
Configuration has not been modified since last system restart.
pixfirewall#

show flash,show interface,show processes,show memory,show running-config,show startup-config ….