Your server is running PHP version 5.1.6 but WordPress 3.7.1 requires at least 5.2.4.

The latest version of wordpress 3.7.1 requires at least php version 5.2.4

[[email protected] ~]# rpm -qa | grep php
php-cli-5.1.6-40.el5_9
php-5.1.6-40.el5_9
php-common-5.1.6-40.el5_9
php-mysql-5.1.6-40.el5_9
php-gd-5.1.6-40.el5_9
php-pdo-5.1.6-40.el5_9

[[email protected] ~]# yum erase php*
Loaded plugins: fastestmirror, security
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package php.i386 0:5.1.6-40.el5_9 set to be erased
---> Package php-cli.i386 0:5.1.6-40.el5_9 set to be erased
---> Package php-common.i386 0:5.1.6-40.el5_9 set to be erased
---> Package php-gd.i386 0:5.1.6-40.el5_9 set to be erased
---> Package php-mysql.i386 0:5.1.6-40.el5_9 set to be erased
---> Package php-pdo.i386 0:5.1.6-40.el5_9 set to be erased
--> Finished Dependency Resolution
.........................
.........................

Now, we have to install php 5.3

[[email protected] ~]# yum install php53 php53-gd php53-mysql
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
* base: mirror.telepoint.bg
* extras: mirror.telepoint.bg
* updates: mirror.telepoint.bg
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53.i386 0:5.3.3-21.el5 set to be updated
--> Processing Dependency: php53-cli = 5.3.3-21.el5 for package: php53
--> Processing Dependency: php53-common = 5.3.3-21.el5 for package: php53
---> Package php53-gd.i386 0:5.3.3-21.el5 set to be updated
---> Package php53-mysql.i386 0:5.3.3-21.el5 set to be updated
--> Processing Dependency: php53-pdo for package: php53-mysql
--> Running transaction check
---> Package php53-cli.i386 0:5.3.3-21.el5 set to be updated
---> Package php53-common.i386 0:5.3.3-21.el5 set to be updated
---> Package php53-pdo.i386 0:5.3.3-21.el5 set to be updated
--> Finished Dependency Resolution

[email protected] ~]# lsb_release -a
LSB Version: :core-4.0-ia32:core-4.0-noarch:graphics-4.0-ia32:graphics-4.0-noarch:printing-4.0-ia32:printing-4.0-noarch
Distributor ID: CentOS
Description: CentOS release 5.10 (Final)
Release: 5.10
Codename: Final

Leave a Reply

Your email address will not be published. Required fields are marked *